PHP7安装intl和xsl扩展

背景:解决magento2安装过程中缺少php扩展的问题:ext-intl和ext-xsl

1
2
3
4
5
6
7
8
Loading composer repositories with package information
Installing dependencies (including require-dev) from lock file
Your requirements could not be resolved to an installable set of packages.

Problem 1
- The requested PHP extension ext-intl * is missing from your system. Install or enable PHP's intl extension.
Problem 2
- The requested PHP extension ext-xsl * is missing from your system. Install or enable PHP's xsl extension.

intl

1
2
3
4
5
6
# yum -y install libicu-devel
# cd soft/php-7.1.6/ext/intl
# phpize
# ./configure --enable-intl --with-php-config=/data/server/php7/bin/php-config
# make
# make install

xsl

1
2
3
4
5
6
# yum -y install libxslt libxslt-devel
# cd soft/php-7.1.6/ext/xsl
# phpize
# ./configure --with-xsl --with-php-config=/data/server/php7/bin/php-config
# make
# make install

php.ini

1
2
extension=xsl.so
extension=intl.so

Powered by AppBlog.CN     浙ICP备14037229号

Copyright © 2012 - 2020 APP开发技术博客 All Rights Reserved.

访客数 : | 访问量 :