Glide 4.x找不到AppGlideModule

翻阅Release日志:https://github.com/bumptech/glide/releases

查看Glide 4.5.0 Release更新日志:Glide must be compiled against API 27

也就是说:Glide 4.5.0及以上版本不能使用API 27及以上版本的SDK编译

  • 如果非得使用API 27及以上版本编译,可以使用Glide 4.4.0版本
  • 如果非得使用Glide最新版本,可以使用API 26进行编译
1
2
3
4
dependencies {
implementation "com.github.bumptech.glide:glide:4.4.0"
annotationProcessor 'com.github.bumptech.glide:compiler:4.4.0'
}

参考:http://bumptech.github.io/glide/doc/download-setup.html#android-sdk-requirements

Android SDK Requirements

Minimum SDK Version - Glide requires a minimum SDK version of 14 (Ice Cream Sandwich) or higher.

Compile SDK Version - Glide must be compiled against SDK version 27 (Oreo MR1) or higher.

Support Library Version - Glide uses support library version 27.

If you need or would prefer to use a different version of the support library you should exclude "com.android.support" from your Glide dependency in your build.gradle file. For example, if you’d like to use v26 of the support library:

1
2
3
4
5
6
dependencies {
implementation ("com.github.bumptech.glide:glide:4.7.1") {
exclude group: "com.android.support"
}
implementation "com.android.support:support-fragment:26.1.0"
}

Powered by AppBlog.CN     浙ICP备14037229号

Copyright © 2012 - 2020 APP开发技术博客 All Rights Reserved.

访客数 : | 访问量 :